Commit b989888c authored by David Verelst's avatar David Verelst
Browse files

installation docs: add--no-channel-priority when installing from conda-forge

parent 5e4bf139
......@@ -143,9 +143,16 @@ Install the necessary Python dependencies using the conda package manager:
```
>> conda install setuptools_scm future h5py pytables pytest nose sphinx
>> conda install scipy pandas matplotlib cython xlrd coverage xlwt openpyxl psutil
>> conda install -c https://conda.anaconda.org/conda-forge pyscaffold pytest-cov
>> conda install -c https://conda.anaconda.org/conda-forge pyscaffold pytest-cov --no-channel-priority
```
Note that ```--no-channel-priority``` avoids that newer packages from the
```conda-forge``` will be used instead of those from the default ```anaconda```
channel. Depending on which packages get overwritten, this might brake your
Anaconda root environment. As such, using ```--no-channel-priority``` should be
be used for safety (especially when operating from the root environment).
## Get wetb
Copy the https - link on the front page of your fork of wetb
......
......@@ -9,7 +9,7 @@ Install the necessary Python dependencies using the ```conda``` package manager:
```
conda install setuptools_scm future h5py pytables pytest nose sphinx blosc
conda install scipy pandas matplotlib cython xlrd coverage xlwt openpyxl psutil
conda install -c https://conda.anaconda.org/conda-forge pyscaffold pytest-cov
conda install -c https://conda.anaconda.org/conda-forge pyscaffold pytest-cov --no-channel-priority
```
Now you can install ```wetb``` with ```pip``` (there is no ```conda``` package
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment